Knowledgebase
Knowledgebase > General > Compatibility > Sonic Extensions Compatibility

Sonic Extensions Compatibility

Sonic Extensions operate within Omnisphere and require Omnisphere version 2.8, which was released Tuesday October 19th, 2021. 

Omnisphere 2 must be registered to your Spectrasonics User Account,  installed, and authorized in order to purchase Sonic Extensions. If your Omnisphere 2 version is 2.7 or below, Sonic Extensions will not show up in Omnisphere. For instructions on how to update your Omnisphere to version 2.8, please click here.

If you do not own Omnisphere yet, please visit an authorized reseller near you to purchase the box version. This way, you can get the best deal and the USB installer,  the most convenient installation option, especially for future installations.

Please see the following articles for more compatibility information regarding Spectrasonics Instruments:

General OS Compatibility

Mac OS Compatibility

Windows Compatibility


< back to topics