Knowledgebase

Logic X

The latest versions of our instruments are fully-compatible with Apple's Logic X.

NOTE: Logic X only functions as 64-bit. 32-bit versions of Omnisphere, Trilian or Stylus RMX will not be available on the list of AU Instruments.  If you wish to use the 32-bit versions, you'll need to use Logic 9 in 32-bit mode. Keyscape only works in 64-bit hosts and is compatible with Logic X.


< back to topics