Knowledgebase
Knowledgebase > General > Compatibility > Mac OS Compatibility

Mac OS Compatibility

The latest versions of Omnisphere 2, Keyscape, Trilian and Stylus RMX are supported on the following Mac operating systems: 10.11 El Capitan, 10.12 Sierra, and 10.13 High Sierra. Older versions of our instruments are supported on the operating systems that they were designed and advertised to run on. Our instruments are incompatible with Garageband on High Sierra, as explained here.

Regarding Omnisphere 1, which was released in 2008 and was publicly available through April 2015 (prior to the relase of Omnisphere 2) - Omnisphere 1 is officially supported on Mac OS 10.6 (Snow Leopard) - 10.10 (Yosemite); it will not install on 10.12 (Sierra) and later.

If you would like to use an older version of Omnisphere, make sure it is installed on a supported operating system.

If you have an older version of Omnisphere and would like to use it on Mac OS 10.12 (Sierra), simply upgrade to the latest version of Omnisphere here

The latest version of Omnisphere contains many added features and sounds in addition to compatibility with 10.12 Sierra and full backwards compatibility with older versions of Omnisphere.


< back to topics